Upgrade to Java 11 on reference-api

Description

Need to figure out how to fix “Failed to execute goal org.codehaus.groovy.maven:gmaven-plugin:1.0:execute (default) on project hspc-reference-api-parent: Execution default of goal org.codehaus.groovy.maven:gmaven-plugin:1.0:execute failed: Unable to load the mojo 'execute' in the plugin 'org.codehaus.groovy.maven:gmaven-plugin:1.0' due to an API incompatibility: org.codehaus.plexus.component.repository.exception.ComponentLookupException: null“.

 

We need to figure out where does groovy/gmaven gets pulled in, it is not in our code base.

 

PS - when doing the java upgrade, it was suggested to comment/get rid of spring-boot-maven-plugin, jacoco plugin from throughout the project.

Assignee

Shilpy Sharma

Reporter

Shilpy Sharma

Labels

None

Priority

Major
Configure